car clicks when turning ignition - Page 2
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29
Like Tree1Likes

Thread: car clicks when turning ignition

  1. #11
    Nooblets CNelms's Avatar
    Join Date
    Apr 2017
    Location
    Church Hill, TN
    Posts
    36
    Quote Originally Posted by 9thgenBae View Post
    Wait is the battery brand new?
    The battery was purchased January 2018

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #12
    Nooblets
    Join Date
    Apr 2017
    Posts
    46
    Quote Originally Posted by CNelms View Post
    Quote Originally Posted by 9thgenBae View Post
    Wait is the battery brand new?
    The battery was purchased January 2018
    gotcha, well either way that amp could definitely be ovedrawing your electrical system. It could be killing the battery and could even be drawing more than your alternator can generate. I believe I have heard of high power amp users having to install stronger alternators. Regardless I would say your best bet is the battery , and if that fixes your issue and it happens again within a year again then the amp could be causing your problems

  4. #13
    Big Pimping!!! dpetro1's Avatar
    Join Date
    Jun 2014
    Location
    Catonsville, MD
    Posts
    890
    To me, this sounds like loose battery terminals or a failing starter. Especially since its intermittent and getting worse over time.

    Sent from my SM-G920V using Tapatalk

  5. Remove Advertisements
    9th Civic
    Advertisements
     

  6. #14
    Nooblets Aviator6's Avatar
    Join Date
    Jul 2018
    Location
    Charleston, WV
    Posts
    87
    Check the ground cables at the frame and engine. Loose, corroded?
    Teeps likes this.
    2013 Civic Si /// 2019 Pilot EX-L

  7. #15
    Greenhorn J9thGen's Avatar
    Join Date
    Feb 2014
    Posts
    21
    I had the same problem before and with 1000w of sounds. I had to grab a wire and jump the starter, make sure it's in neutral and ignition on. Always starts that way so I thought it's not the battery. But when I changed the battery it never had that problem again. It just didn't have enough cold cranking amps. Get a battery with good cranking amps and clean and tighten the terminals

  8. #16
    Greenhorn
    Join Date
    Oct 2018
    Posts
    4
    I work for a honda dealer. Based on the click it sounds like a starter that is going bad .

  9. #17
    Greenhorn
    Join Date
    Nov 2014
    Posts
    5
    I had a similar issue in my 2015. It was intermittent, probably happened twice or 3 times -- the car just wouldn't start. I had the ignition relay replaced and have never had a problem since. Unfortunately I don't remember though if there was a click involved though.

  10. #18
    Nooblets CNelms's Avatar
    Join Date
    Apr 2017
    Location
    Church Hill, TN
    Posts
    36
    Quick update: Went to Autozone and had them change the battery also cleaned the terminals when installing the new one and checked the grounds to the battery. Started first try no problem but on the second attempt again just a click. I guess I'm going for the starter next

  11. #19
    Nooblets CNelms's Avatar
    Join Date
    Apr 2017
    Location
    Church Hill, TN
    Posts
    36
    The one thing that makes me wonder if it isn't the starter is the car starts without issue when it doesn't just click. It doesn't sound like it is struggling at all when it actually attempts to start

  12. #20
    Big Pimping!!! dpetro1's Avatar
    Join Date
    Jun 2014
    Location
    Catonsville, MD
    Posts
    890
    Quote Originally Posted by CNelms View Post
    The one thing that makes me wonder if it isn't the starter is the car starts without issue when it doesn't just click. It doesn't sound like it is struggling at all when it actually attempts to start
    There are brushes inside the starter that transmit the electrical current. If they intermittently don't get a connection then you get a click and no start.

    Sent from my SM-G920V using Tapatalk

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. car loses power when i press ignition, no power at all until i pull the battery termi
    By fuzzysig in forum Mechanical Problems & Technical Chat
    Replies: 6
    Last Post: 12-11-2018, 08:15 AM
  2. Weird clicking sound when turning ignition
    By CaptainJango in forum Mechanical Problems & Technical Chat
    Replies: 0
    Last Post: 06-27-2015, 07:11 PM
  3. No response from car when I switch ignition
    By DerekJA in forum Mechanical Problems & Technical Chat
    Replies: 2
    Last Post: 12-12-2013, 04:00 AM
  4. AEM FIC (Fuel ignition controller)
    By AllAboutAlloy in forum ECU Tuning
    Replies: 6
    Last Post: 08-23-2012, 11:48 AM
  5. MSD Ignition on Civic SI?
    By casualvic in forum Engine, Engine Swaps, Pulleys, Injectors
    Replies: 3
    Last Post: 03-03-2012, 07:28 AM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2