Clutch Chatter!?!.
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By DCFIVER

Thread: Clutch Chatter!?!.

  1. #1
    Greenhorn
    Join Date
    Aug 2019
    Posts
    2

    Clutch Chatter!?!.

    Sometimes as I'm releasing the clutch to engage into 1st gear I hear a "chatter" just right as I'm about to release the clutch all the way.. the actual sound of chatter.. like tapping of a metal.. not a grind or a grrr.. just good ole chatter lol... who else?

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #2
    Greenhorn
    Join Date
    Jun 2019
    Location
    Failing a car near you....
    Posts
    29
    Its common.

    You can search on it, but basically you need a new clutch assembly...
    SiDan2015 likes this.

  4. #3
    Greenhorn
    Join Date
    Dec 2018
    Location
    Washington, DC
    Posts
    20
    Agreeing with DCFIVER. A not uncommon issue with the 9th gen SIs. Word on the street is that while annoying, it's not a symptom of a bad clutch overall. Don't try to use warranty, if you have one. I went down the route already, and it didn't pan out. My '15 Si developed clutch chatter in 1st gear upon clutch release as well. And at around 20,000 miles too. Assuming I still have the car for another 30k miles I'll just replace the clutch someday and hope it stops.

  5. Remove Advertisements
    9th Civic
    Advertisements
     

  6. #4
    Greenhorn
    Join Date
    Jul 2019
    Location
    Sun Diego
    Posts
    7
    I am there with you too PNW9thGenSi. My '15 Si at 70K+ mi is having the same issue. I am looking into replacing my clutch now..not looking forward to that added expense but gotta do what I gotta do to keep the car running smooth.

  7. #5
    Nooblets dbosch's Avatar
    Join Date
    Jun 2012
    Location
    The Dust Bowl
    Posts
    42
    My '12 Si did it starting around 25K miles. I'm now at 89K miles and it still does it, the exact same way with no drive-ability issues. Leave it alone until the clutch slips and needs replacement.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2