unset readiness codes
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: unset readiness codes

  1. #1
    Greenhorn
    Join Date
    Jan 2017
    Posts
    15

    unset readiness codes

    Hello,I have a 2015 Honda Civic Si, I have reflashed back to stock tune to pass my states safety and emissions annual test; I have disabled the primary O2 sensor, given I have an aftermarket catted downpipe and cat back exhaust system (K Tuned). Since the reflash I have logged/driven several hundred miles, today (10-20-2018) it failed the state test due to it not being ready, to many unset readiness codes ( Catalyst, Fuel System and Evaporative System). Is this normal? How long and and could the primary O2 sensor being disabled cause this not readiness codes? Anything you can recommend b/c I am in a serious time crunch to complete this state inspection. Thank you
    George

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #2
    Nooblets
    Join Date
    Aug 2018
    Location
    Boston, MA
    Posts
    81
    Anytime you switch a tune, it’s like pulling the battery and all the sensors need some time to reset. You just need to drive around 100 miles before going to do emissions testing next time. All of the emission sensors should turn on by then.


    Sent from my iPhone using Tapatalk

  4. #3
    Truck? What truck?! scottyrocks's Avatar
    Join Date
    Nov 2012
    Location
    Isle of Langerhan, NY
    Posts
    26,823
    He said he drove several hundred miles after the reflash.
    'Three pedals or bust!'
    'Come for the cars. Stay for the people.'
    'Part of having the right to free speech is knowing when to not exercise it.'
    ‘Say what you mean, mean what you say, but don’t say it mean.’
    9th Gen Civic POP Crew #6 Hidden Content
    9th Gen Civic LI Crew#1 Hidden Content

  5. Remove Advertisements
    9th Civic
    Advertisements
     

  6. #4
    Nooblets
    Join Date
    Apr 2017
    Posts
    44
    Quote Originally Posted by GeoUCF14 View Post
    Hello,I have a 2015 Honda Civic Si, I have reflashed back to stock tune to pass my states safety and emissions annual test; I have disabled the primary O2 sensor, given I have an aftermarket catted downpipe and cat back exhaust system (K Tuned). Since the reflash I have logged/driven several hundred miles, today (10-20-2018) it failed the state test due to it not being ready, to many unset readiness codes ( Catalyst, Fuel System and Evaporative System). Is this normal? How long and and could the primary O2 sensor being disabled cause this not readiness codes? Anything you can recommend b/c I am in a serious time crunch to complete this state inspection. Thank you
    George
    I believe you are referring to the secondary o2 sensor as most tunes do not disable the primary , atleast that im aware of. Regardless, disabling the secondary o2 sensor will cause the Oxygen Sensor Monitoring monitor to not complete, AND that monitor is required for the Catalyst Monitoring check to ready up too. So you will have those 2 monitors not ready from having the secondary o2 sensor disabled (this is what happened to my car)

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. Replies: 30
    Last Post: 09-20-2017, 06:18 AM
  2. Evap system pressure/ evap system readiness
    By 13Si-vtec in forum Mechanical Problems & Technical Chat
    Replies: 6
    Last Post: 09-21-2016, 06:37 AM
  3. Random Misfire Codes Bad Coil Codes Need Help !!!!
    By dyoo85 in forum Mechanical Problems & Technical Chat
    Replies: 15
    Last Post: 09-26-2015, 09:02 AM
  4. Inspection readiness failed
    By tyte07 in forum Mechanical Problems & Technical Chat
    Replies: 10
    Last Post: 09-05-2015, 06:53 AM
  5. Chassis Codes?
    By MDK20FG2 in forum General Maintenance
    Replies: 65
    Last Post: 02-14-2013, 10:37 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2