Need help 2015 Honda Civic Si 103k miles
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By Aviator6

Thread: Need help 2015 Honda Civic Si 103k miles

  1. #1
    Greenhorn
    Join Date
    Aug 2015
    Location
    Lewisburg, PA
    Posts
    16

    Need help 2015 Honda Civic Si 103k miles

    Battery and alternator were changed in the past year same with the drive belt. I started my car up and the “check charging system” light came on. I drove for a little bit then the “check airbag light” came on so I shut the car off to see if it would reset and it wouldn’t start again.. had power and the 4 ways worked but the AC and stuff wasn’t working. I got stuck on the highway was able to pop the clutch to start it and the codes went away, I took it to advanced auto and they check the charging system and battery and everything was good ... drove the car more and the charging system light came on and eventually as I was driving everything went out on me ... the lights the powersteering I mean everything the AC The audio system and it lit up like a Christmas tree telling to me check this and this system and that system... it dangerous as hell to be driving the dam thing...anyone have the same issue please add your input

    Thank you much appreciated

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #2
    Nooblets Aviator6's Avatar
    Join Date
    Jul 2018
    Location
    Charleston, WV
    Posts
    87
    Check & clean all the battery connections and especially the ground connections to the frame and engine.
    Teeps likes this.
    2013 Civic Si /// 2019 Pilot EX-L

  4. #3
    Truck? What truck?! scottyrocks's Avatar
    Join Date
    Nov 2012
    Location
    Isle of Langerhan, NY
    Posts
    26,969
    Please post threads only once, in what you feel is the most appropriate forum or subforum, thanks.
    'Three pedals or bust!'
    'Come for the cars. Stay for the people.'
    'Part of having the right to free speech is knowing when to not exercise it.'
    ‘Say what you mean, mean what you say, but don’t say it mean.’
    9th Gen Civic POP Crew #6 Hidden Content
    9th Gen Civic LI Crew#1 Hidden Content

  5. Remove Advertisements
    9th Civic
    Advertisements
     

  6. #4
    Big Pimping!!! dpetro1's Avatar
    Join Date
    Jun 2014
    Location
    Catonsville, MD
    Posts
    891
    Check the belt tension. Was the tensioner replaced when you did the belt?

    Sent from my SM-G920V using Tapatalk

  7. #5
    Greenhorn
    Join Date
    Aug 2015
    Location
    Lewisburg, PA
    Posts
    16
    Alternator is shot gonna send it back on warranty ... figured it out by running the car and pulling the battery terminals off and it immediately shutting off

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2