Main Navigation system screen and A/C black at the same time(Civic Si 2014)
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Results 1 to 2 of 2

Thread: Main Navigation system screen and A/C black at the same time(Civic Si 2014)

  1. #1
    Greenhorn
    Join Date
    May 2019
    Posts
    1

    Exclamation Main Navigation system screen and A/C black at the same time(Civic Si 2014)

    Guys , I had this big problem with my Civic Si 2014. The Navigation screen and the A/C LCD display went black and they both stopped working at the same time. Did anyone experience this? I checked the fuses, and they are all working. Can someone please help me?

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #2
    Big Timer!!!
    Join Date
    Nov 2016
    Location
    Round Rock, TX
    Posts
    114
    That happened to me when my battery was starting to die.
    2015 Civic Si Sedan / MSM
    POP Crew Member #53

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. DIY: 2014 Si Navigation into a 2013 Si Non-Navigation
    By jdmasf_ck in forum Audio/Video/Navi
    Replies: 9
    Last Post: 01-25-2019, 12:24 PM
  2. Replies: 0
    Last Post: 04-06-2017, 02:16 PM
  3. Switch 2013 si stereo system with 2014 touch screen?
    By athao25 in forum Audio/Video & Navigation
    Replies: 9
    Last Post: 01-18-2016, 05:10 PM
  4. Night time running main brake lights?
    By Synapse in forum Exterior
    Replies: 0
    Last Post: 07-09-2013, 04:35 PM
  5. navigation system screen not bright enough when starting up the vehicle?
    By amalheiro in forum Audio/Video & Navigation
    Replies: 3
    Last Post: 10-16-2012, 08:50 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2