2012 Civic - ABS VSA and Power Steering Check Lights come on while driving...
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Results 1 to 7 of 7

Thread: 2012 Civic - ABS VSA and Power Steering Check Lights come on while driving...

  1. #1
    Greenhorn
    Join Date
    Jun 2015
    Posts
    1

    2012 Civic - ABS VSA and Power Steering Check Lights come on while driving...

    I have a 2012 Honda Civic I have owned since new. I have had the ABS VSA and Power Steering Check Lights come on while driving come on randomly about 4-5 times. The car goes immediately into limp mode, and as I slow down, it starts to jerk, so I put it in neutral. Shut down the car and restart to clear. Initially, I took back to Honda and they looked at it and upgraded some program. That help for a while, but its come back recently randomly. My main concern is when this happens when I am driving at higher speed in traffic. I see some other folks have reported same problem but there seems to be no clear solution. Anyone know if this is a recall item?

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #2
    Big Timer!!! '13_Si's Avatar
    Join Date
    May 2014
    Posts
    185
    Is the engine light blinking or solid? What trim and transmission do you have?

  4. #3
    Truck? What truck?! scottyrocks's Avatar
    Join Date
    Nov 2012
    Location
    Isle of Langerhan, NY
    Posts
    26,962
    Have you checked to see if the fuse is in some way partially damaged, like a bulb that goes off and on before finally failing?
    'Three pedals or bust!'
    'Come for the cars. Stay for the people.'
    'Part of having the right to free speech is knowing when to not exercise it.'
    ‘Say what you mean, mean what you say, but don’t say it mean.’
    9th Gen Civic POP Crew #6 Hidden Content
    9th Gen Civic LI Crew#1 Hidden Content

  5. Remove Advertisements
    9th Civic
    Advertisements
     

  6. #4
    Platinum Member Teeps's Avatar
    Join Date
    Feb 2013
    Location
    Torrance, CA
    Posts
    2,713
    Quote Originally Posted by morrisroad View Post
    I have a 2012 Honda Civic I have owned since new. I have had the ABS VSA and Power Steering Check Lights come on while driving come on randomly about 4-5 times. The car goes immediately into limp mode, and as I slow down, it starts to jerk, so I put it in neutral. Shut down the car and restart to clear. Initially, I took back to Honda and they looked at it and upgraded some program. That help for a while, but its come back recently randomly. My main concern is when this happens when I am driving at higher speed in traffic. I see some other folks have reported same problem but there seems to be no clear solution. Anyone know if this is a recall item?
    Did the dealer check the battery & charging system?
    They should have given you a printout if they did.
    Did they check for DTCs?

    Does your car have any mods electrical or otherwise?
    Go here: Hidden Content
    Because misinformation is far worse; than NO information...


  7. #5
    Big Timer!!!
    Join Date
    Apr 2012
    Location
    Eastvale, CA
    Posts
    167
    I had lost the bracket for the throttle body while I was installing my P2R spacer. I was only able to tighten the throttle body down with two bolts instead of four and drove around like that until the new bracket came in from honda. I knew it was going to leak in air for sure causing the car to run lean and throw some codes. The Abs, VSA, and Powerstreeing lights came on my dash while waiting for the new part to arrive. Car would also go into limp mode and fuel cut at 3500rpm. So it sounds like you might have a vacuum leak or even a leak on the intake side of the engine, anywhere after the maf sensor and before the cylinder head.

  8. #6
    Greenhorn
    Join Date
    Jul 2015
    Posts
    11
    I have same issue comes and goes i pulled codes when i worked at the dealership thinkin i would find a dtc characteristic of them all but each is different. We have replaced a gas pedal...yes a gas pedal. For that issue and it fixed the car it was like a deadspot and when you hit it just right everything went crazy. But not so lucky on my car i am most likely gonna change the vsa module bein its in the trouble shooting guide for the dtcs cause that will also affect abs and it should fix the problem im hoping. If anyone has these issues make sure to go to the dealer and have them call tech line to see if they seen it anywhere else from dealers each car is different. Sorry if not much help just glad not only one with the issue

  9. #7
    Greenhorn
    Join Date
    May 2016
    Posts
    1
    Quote Originally Posted by Daniel View Post
    I had lost the bracket for the throttle body while I was installing my P2R spacer. I was only able to tighten the throttle body down with two bolts instead of four and drove around like that until the new bracket came in from honda. I knew it was going to leak in air for sure causing the car to run lean and throw some codes. The Abs, VSA, and Powerstreeing lights came on my dash while waiting for the new part to arrive. Car would also go into limp mode and fuel cut at 3500rpm. So it sounds like you might have a vacuum leak or even a leak on the intake side of the engine, anywhere after the maf sensor and before the cylinder head.

    I have the same issue now. Honda threw a MAF/Temp Sensor on it and some sort of Voltage Regulator Fuse/Relay thing, no dice. Checked all fuses and couldn't diagnose this. He seems to think it there was a short in the wiring harness probably from an oversized fuse. He said he found a couple that were the wrong size so he replaced them but car still doesn't run over 3500 RPM and that's only with the MAF/Temp Sensor unplugged.

    Has anyone else had any luck with this? I'm going to check again for intake leaks but I don't see anything as of yet. I did have to replace a breather line that had dry rotted and I'd hoped that was it. But it still has the same issues.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. VSA/ABS/Power Steering Lights come on - HIDs?
    By SKCanada in forum 9th Gen Civic General Chat
    Replies: 3
    Last Post: 08-22-2013, 05:32 PM
  2. ABS VSA and Power Steering warning lights
    By deelek in forum Mechanical Problems & Technical Chat
    Replies: 2
    Last Post: 08-11-2013, 12:43 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2