2014 civic si will drop rpms and sometimes stall
  1. Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation – General discussion forum for 9th Gen Civic

    Welcome to 9th Gen Civic Forum : 2012 Honda Civic Forums - 9th Generation - a website dedicated to all things 9th Gen Civic.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join 9th Gen Civic today!
     
+ Reply to Thread
Results 1 to 9 of 9
Like Tree3Likes
  • 2 Post By dpetro1
  • 1 Post By 9thgensifamily

Thread: 2014 civic si will drop rpms and sometimes stall

  1. #1
    Greenhorn
    Join Date
    Mar 2018
    Posts
    14

    2014 civic si will drop rpms and sometimes stall

    My si has recently been dropping rpms then catching itself before stalling when I coast in neautral but occasionally it will stall but it will start back up immediately, does anyone have any guesses on what could be causing this

  2. Remove Advertisements
    9th Civic
    Advertisements
     

  3. #2
    Big Pimping!!! dpetro1's Avatar
    Join Date
    Jun 2014
    Location
    Catonsville, MD
    Posts
    904
    How many miles? Any aftermarket modifications? Are you getting any CEL?

    Sent from my SM-G920V using Tapatalk
    procivic and Teeps like this.

  4. #3
    Top Dawg!! bfaided1984's Avatar
    Join Date
    Oct 2017
    Location
    Dallas
    Posts
    1,226
    Quote Originally Posted by dpetro1 View Post
    How many miles? Any aftermarket modifications? Are you getting any CEL?

    Sent from my SM-G920V using Tapatalk
    What he said. We need a little more info to help ya out.
    Whenever I'm suffering from Insomnia, I just look at a picture of a Toyota Camry and I'm straight off.
    INSTAGRAM: that_stock_fb6

  5. Remove Advertisements
    9th Civic
    Advertisements
     

  6. #4
    Nooblets Aviator6's Avatar
    Join Date
    Jul 2018
    Location
    Charleston, WV
    Posts
    94
    How stable is the idle when stopped, with the engine warmed up?
    2013 Civic Si /// 2019 Pilot EX-L

  7. #5
    Greenhorn
    Join Date
    Mar 2018
    Posts
    14
    I have a rbc manifold, intake, catless downpipe, skunk 2 exhaust, 1000cc injectors as well as being dyno tuned

  8. #6
    Greenhorn
    Join Date
    Mar 2018
    Posts
    14
    Also I’m almost to 28k miles and the engine isles fine even when warm

  9. #7
    Big Pimping!!! dpetro1's Avatar
    Join Date
    Jun 2014
    Location
    Catonsville, MD
    Posts
    904
    Did this just start? Who tuned it? I would either say something with the tune or maybe a vacuum leak.

    Sent from my SM-G920V using Tapatalk

  10. #8
    Greenhorn
    Join Date
    Mar 2018
    Posts
    14
    This started happening 2 months after the car was tuned, but I had driven it from Seattle to San Diego before it became an issue

  11. #9
    Big Timer!!! 9thgensifamily's Avatar
    Join Date
    Apr 2015
    Posts
    227
    My car does this on occasion as well, seems only when starting with a hot engine. Helps to start it and feather throttle a bit. I believe its something to do with 1,000cc injectors and the extremely low pulse required for idle. May be heat soak of OBD1 style IAT sensor, being speed density tuned as well...it hasn't bothered me much.

    Those are big injectors for a bolt on build aren't they?
    Teeps likes this.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. A/C on causes RPMS to drop quickly and cause jerky shifting
    By kevvo21 in forum Mechanical Problems & Technical Chat
    Replies: 11
    Last Post: 10-29-2017, 12:40 PM
  2. 2012 Manual LX Freeway RPMs and MPG
    By Wykyd in forum 9th Gen Civic General Chat
    Replies: 11
    Last Post: 10-08-2015, 07:13 AM
  3. Engine "Stall" During Low Speed Acceleration
    By VernHey in forum Drivetrain Problems
    Replies: 6
    Last Post: 01-19-2013, 05:01 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2