9th Gen Civic Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have just recently purchased a new to me civic from a dealership in the Toronto area, non the less the car only has heat at the "hi" setting on the temp control and no actual heat on the lower settings 28 and under. I did the thermostat last night dec 21 and I let all the air bubbles come to the surface in the coolant while the car got to operating temp and when the thermostat would do it's normal thing. I'm wondering what else I must have as an issue I do live in Ontario Canada and for some reason the ambient air sensor reads out 55c when it's been no warmer then 8c this whole month as its winter time. If anyone has help or has had this issue I would love to have the help to fix it myself thanks
 

·
Registered
Joined
·
2,893 Posts
I have just recently purchased a new to me civic from a dealership in the Toronto area, non the less the car only has heat at the "hi" setting on the temp control and no actual heat on the lower settings 28 and under. I did the thermostat last night dec 21 and I let all the air bubbles come to the surface in the coolant while the car got to operating temp and when the thermostat would do it's normal thing. I'm wondering what else I must have as an issue I do live in Ontario Canada and for some reason the ambient air sensor reads out 55c when it's been no warmer then 8c this whole month as its winter time. If anyone has help or has had this issue I would love to have the help to fix it myself thanks
How many km?
 
1 - 5 of 5 Posts
Top