9th Gen Civic Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all!

Recently I found that my Civic was stuttering a bunch to start. It would click a struggle and then finally kick in and start. I started with replacing the battery. After a couple starts it again had difficulty. The next step I took was replacing the alternator. Started right up leaving the shop. The following start proved that the alternator was not the issue. Right back to clicking. While it idled in the driveway, I started looking for things that could be killing my electrical system. Turning the heat on produce a electrical burning smell from the area near the alternator. When I turned the steering wheel, the touchscreen and stereo would make a lonud pop, go out, and come back on. I just can’t quite figure out what might be causing the issue? Maybe a ground or loose wire? Has anyone had similar issues? I’m hesitant to take it to the dealership and have them hunt for hours for the issue. Any help would be appreciated!
 

·
Registered
Joined
·
3 Posts
Hey all!

Recently I found that my Civic was stuttering a bunch to start. It would click a struggle and then finally kick in and start. I started with replacing the battery. After a couple starts it again had difficulty. The next step I took was replacing the alternator. Started right up leaving the shop. The following start proved that the alternator was not the issue. Right back to clicking. While it idled in the driveway, I started looking for things that could be killing my electrical system. Turning the heat on produce a electrical burning smell from the area near the alternator. When I turned the steering wheel, the touchscreen and stereo would make a lonud pop, go out, and come back on. I just can’t quite figure out what might be causing the issue? Maybe a ground or loose wire? Has anyone had similar issues? I’m hesitant to take it to the dealership and have them hunt for hours for the issue. Any help would be appreciated!
I had some of this happen to me, I just needed to replace the battery
 

·
Registered
Joined
·
1 Posts
Hey all!

Recently I found that my Civic was stuttering a bunch to start. It would click a struggle and then finally kick in and start. I started with replacing the battery. After a couple starts it again had difficulty. The next step I took was replacing the alternator. Started right up leaving the shop. The following start proved that the alternator was not the issue. Right back to clicking. While it idled in the driveway, I started looking for things that could be killing my electrical system. Turning the heat on produce a electrical burning smell from the area near the alternator. When I turned the steering wheel, the touchscreen and stereo would make a lonud pop, go out, and come back on. I just can’t quite figure out what might be causing the issue? Maybe a ground or loose wire? Has anyone had similar issues? I’m hesitant to take it to the dealership and have them hunt for hours for the issue. Any help would be appreciated!
I have a 2015 SI coupe. I personally have not done any mods, only Possible aftermarket mods I’ve seen that the previous owner could have made are HID fog lights?
I just recently experienced the loud pop stereo/touchscreen issue when turning the steering wheel issue. 3 times in 3 days. I haven’t had a chance to dig into it, but my first thought is to check my battery terminals. Did you ever find a definite cause for your issue??
 

·
Registered
Joined
·
1 Posts
When the battery is low the radio seems to make a pop noise. Happened to me once and the car cranked real hard to start but still have a little bit left to start. I know the battery was low because interior lights were all dim
 
1 - 4 of 4 Posts
Top