9th Gen Civic Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
I just installed the afe Intake and the Check Emissions, VSA, and Power steering came on... I believe the intake is on correctly... Will it go off by itself?
 

·
Registered
Joined
·
128 Posts
Discussion Starter #3
Check Emissions/VSA/Power Steering light after afe Takeda intake install

Title pretty much says it. These lights turn on after I start my car after the SRI install. However, I did forget to attach the MAF sensor the first time. Is it stuck in my engine now and I need to disconnect battery? Or is this something the car will adjust to. Honestly, I don't think I can take it to the dealer because the intake is an aftermarket part, and they'd probably say... "Nope".

I'm somewhat scared to test drive it, should i give it a go around the neighborhood a bit?

Thanks for the help!
 

·
Registered
Joined
·
128 Posts
Discussion Starter #5
Battery was not disconnected during install, it is now. I'm waiting 10 minutes. All connections are sealed and tight. Hoping the battery does it. Thanks guys, I'll let you know how it goes.
 
  • Like
Reactions: IvynSteez

·
Registered
Joined
·
128 Posts
Discussion Starter #6
And... Brilliant. Thanks guys. It was the battery. Normal start. Took a drive, works fine. I'll remember that for next time. Problem Solved!
 

·
Registered
Joined
·
70 Posts
Yeah that had happened to me when I had installed my cai. Glad it was all figured out.
 
1 - 7 of 7 Posts
Top