9th Gen Civic Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,711 Posts
Discussion Starter #1
Hi everyone! It has been quite some time since I've been on here. That's what a 3 and 1 year old kids will do to you I suppose!

Anyway, with 80k miles on the clock my '12 Si coupe finally needed new rotors and pads. My rears had been changed before but I was having issues and actually had the rear calipers replaced as well. When I got home I noticed that the front pads don't seem to be big enough to make contact with the entire front rotor. Is this normal or did they install pads that were too small?

Here are some pics:
492163

492164


Is this something that you would bring back to the shop to fix? Was done at a local shop with a pretty good reputation. I only use my car to commute to work. I would love to hear your thoughts and I hope that you're all doing well.
 

·
Registered
Joined
·
1,279 Posts
Do you know what brand or Part# they used? Do the pads seem to be seated into the caliper properly?

Honestly, I think it looks pretty normal.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
1,711 Posts
Discussion Starter #3
Looks like they used Wagner ceramic pads on the front and I imagine the same on the rear. They seem to be seated into the caliper just fine. They are quiet and stopping my car fine so far as well...granted I've only driven like 6 miles.

I'll just trust that the shop knows what they're doing, they're pretty reputable. For whatever reason I just found it strange that the whole surface of the rotor wasn't being used. I don't remember that happening on my original pads and rotors.
 
1 - 3 of 3 Posts
Top