9th Gen Civic Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
So one day as I was driving both my radio and imid display flashed white and both went out(completely black). I lost function to my radio, side/back camera and imid controls. A few days later my radio started working just fine and now it’s just my imid.

my imid would occasionally display only when my headlights were on( kind of dim) but it doesn’t do that anymore and is completely black now. You can tell the imid is “on”cause you can tell the black screen is backlit like when you shut off your iPhone. And when you press the steering wheel controls you still hear the beeps just the screen not displaying.

Yes, I have checked all fuses and they are all fine. I have also hard reset ecu by disconnecting battery terminals. Nothing works. Would it be a software or a hardware issue (as in the imid screen itself)? Need help so I can reset tpms and see what code popped up on imid. Obd2 scanner read no codes as well. Thanks in advance!
 

·
Registered
Joined
·
2 Posts
After checking all the fuses, fault codes and that I did not have any electrical problem, I decided to change the part and indeed the IMID did not work, I only changed the part and it worked perfectly, I will only make sure that the part was compatible with my model of car for example for the Civic Si k24z7 the parts start with 78260-TR7 and for the Civic engine r18 they have part 78260-TR3 (they have more models of parts) It would be good to ensure and change for the OEM number that brings back the IMID
 
1 - 3 of 3 Posts
Top