9th Gen Civic Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
So I bought a j37 throttle body for my supercharged civic si and I’m having surge at idle. I can’t get the adjustment screw to break free. Does anyone have any tips to get it out without stripping the screw?
 

·
Registered
Joined
·
404 Posts
Honestly, you may not even need to adjust it.

Often the issue is that you need to go through the idle relearn process first, rather than the screw needs adjustment. The advice posted from Vitviper saying that the screw needed adjustment for setting these up is bogus. I've used the MDX and RDX TBs new and used and unless the screws were adjusted way out of wack before you, the OEM setting works perfect.

Just google Honda idle relearn. It's the same for every Honda. Also as a tip, you should hear the car go from surging to suddenly idling normally when it's done. It also doesn't always take 5 minutes.

Hope that helps! Let us know if that sorted it.
 

·
Vendor
Joined
·
628 Posts

·
Registered
Joined
·
404 Posts

·
Premium Member
Joined
·
1,839 Posts
I went round in circles for months trying to get 2 different J37 TB's to work for my 2012 Si. Both brand new TB's from PRL. I only got a hunting idle.

The idle relearn didn't work for me. Adjusting the idle set screw didn't work. I did several attempts at both, with no success. Quite frustrating. An extra 15-ish WHP with the CTE setup is like a carrot hanging in front of my face.
 

·
Vendor
Joined
·
628 Posts
I went round in circles for months trying to get 2 different J37 TB's to work for my 2012 Si. Both brand new TB's from PRL. I only got a hunting idle.

The idle relearn didn't work for me. Adjusting the idle set screw didn't work. I did several attempts at both, with no success. Quite frustrating. An extra 15-ish WHP with the CTE setup is like a carrot hanging in front of my face.
Try adjusting the tune to compensate, doing it this way has worked every single time for us.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #7
I tried idle relearn and screw adjustment and neither worked. I just put the stock tb back on. After trying to figure it out for 3 days I give up.
 

·
Registered
Joined
·
99 Posts
Honestly, you may not even need to adjust it.

Often the issue is that you need to go through the idle relearn process first, rather than the screw needs adjustment. The advice posted from Vitviper saying that the screw needed adjustment for setting these up is bogus. I've used the MDX and RDX TBs new and used and unless the screws were adjusted way out of wack before you, the OEM setting works perfect.

Just google Honda idle relearn. It's the same for every Honda. Also as a tip, you should hear the car go from surging to suddenly idling normally when it's done. It also doesn't always take 5 minutes.

Hope that helps! Let us know if that sorted it.
This is how mine went. I didn’t have to adjust anything. It was bolted on and the car was tuned. Work just like stock.
 
1 - 9 of 9 Posts
Top