9th Gen Civic Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2012 Honda Civic Si. The only after market is a cold air intake (AEM). After I replaced the alternator, I took it on the highway and after about 20 miles I had a blinking battery light as well as check engine light. Codes were P0300-0304. I checked the spark plugs, fuel injectors, coils, cams, crankshaft, and intake. Also had the ECM replaced. I have had a couple mechanics look at it and can't figure out what's wrong. When I am on the high way and I let off the gas on the highway it feels like the engine does a shutter and then returns to normal. After quite a few of these it goes into limp home mode. Please help!
 

·
Registered
Joined
·
1,284 Posts
I have a 2012 Honda Civic Si. The only after market is a cold air intake (AEM). After I replaced the alternator, I took it on the highway and after about 20 miles I had a blinking battery light as well as check engine light. Codes were P0300-0304. I checked the spark plugs, fuel injectors, coils, cams, crankshaft, and intake. Also had the ECM replaced. I have had a couple mechanics look at it and can't figure out what's wrong. When I am on the high way and I let off the gas on the highway it feels like the engine does a shutter and then returns to normal. After quite a few of these it goes into limp home mode. Please help!
I think I have seen on here that aftermarket alternators don't always work well with these motors. Hopefully somebody will chime in and confirm or deny this.
 

·
Registered
Joined
·
925 Posts
Why was the alternator replaced?
What is the condition of the battery? Have it tested.
Is your serpentine belt tension correct?

Sent from my SM-G920V using Tapatalk
 
1 - 3 of 3 Posts
Top