9th Gen Civic Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
433 Posts
Discussion Starter #1 (Edited)
Installed my bar about 1,000 miles ago and recently started hearing some strange suspension noises from the rear of the car... here is what I found: See pic
This is the passenger side, the driver's side looks almost as bad but not as bad as this one.
Any clue as to why this would have happened?
I did not over tighten the bushings. I've been installing progress bars on many of my cars for years now... 20+
To say the least, I'm very disappointed.

 

·
Aluminium Member
Joined
·
2,080 Posts
Bad bushing, improperly installed (pinched) bushing, wrong size bushing, wrong size bracket or bracket not completely tightened down... just some thoughts.
 
  • Like
Reactions: BWill9886

·
Registered
Joined
·
46 Posts
You running the stock suspension part? I have (and so do many others) have massive clunking coming from the end links they supply. The nuts and jam nut do not hold tight. THey will not replace and fix this but if you tighten the side you hear the noise from, you'll know thats the issue. My bushings still all seem good but endlinks are junk. I hear the moogs are good but still haven't gotten around to replacing. If you call progress they'll simply tell you to buy another set of end links and then send yours back where they will notice it's user error on installation. Never heard so many mechanics not knowing how to use a torque wrench!? but thats their policy.
 
1 - 3 of 3 Posts
Top