9th Gen Civic Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
new Issue popped up today.

The main Odometer has no information displayed. no mileage at all. trip a, b or the actual miles.


were about to take the vehicle to the dealership. I was just wondering if there were any similar issues reported.

thanks
 

·
Bluestar's winch!!
Joined
·
8,769 Posts
We've seen a member with a flashing display. I don't remember seeing no information. Well, one case was from high heat.
 

·
Registered
Joined
·
405 Posts
Yeah that happened to me just unplug the battery for 30 secs, plug it back in and your golden

Sent from my SPH-D710 using AutoGuide.Com Free App
 

·
Registered
Joined
·
1,810 Posts
Yeah that happened to me just unplug the battery for 30 secs, plug it back in and your golden
Is that the automotive version of CTL-ALT-DLT?
 

·
Registered
Joined
·
5 Posts
same issue happened to me as well
I - Mid is workin(clock,radio station is working)
No trip A , Trip B or Odometer at all
Fuel range is also missing

Did anyone resolve this issue?

Do I need to take my 2012 civic to dealership ?
or

unplug battery wait and plug it in ?
 

·
Registered
Joined
·
52 Posts
I took my car in to the dealership for this same reason and they fixed it within a few minutes. Don't know what they did but they knew what it was.
 

·
Registered
Joined
·
373 Posts
HSB 13-017 Applies to 12 Civic LX and HF

The IMID does not display odometer, trip, range, or economy, this is fixed with a software update.

Disconnecting the battery may reset and work for a while, but is not a permanent fix for the problem.

Please see your Honda dealer.

HTH
 

·
Registered
Joined
·
1 Posts
I have a Civic 2013 and experience the same problem. No information display for the main odometer. They just switching between A and B. I bring my car to the dealer yesterday and they told me that's the way it is, i.e., once you program the A trajet, you loose the main information.Is it true ? Should I believe them ? Please tell me if you know how to fix it.
 

·
Registered
Joined
·
1 Posts
When I called my dealership they had never heard of this happening, told me not to unplug battery next time so they could see codes.
 

·
Registered
Joined
·
1 Posts
Thanks to MikeVZ - this just happened to me today, I Googled, found this thread, disconnected the battery for 30 seconds, reconnected it... voila! I registered for this forum just to thank MikeVZ for saving me a trip to the dealer.
 

·
Registered
Joined
·
1 Posts
Thanks, I am also resolved same problem just unplug the battery (negative) not more than 1 minute. The display back to normal.
 

·
Registered
Joined
·
1 Posts
same issue happened to me as well
I - Mid is workin(clock,radio station is working)
No trip A , Trip B or Odometer at all
Fuel range is also missing

Did anyone resolve this issue?

Do I need to take my 2012 civic to dealership ?
or

unplug battery wait and plug it in ?
it happen to me
 
1 - 20 of 24 Posts
Top