9th Gen Civic Forum banner
1 - 9 of 9 Posts

·
Photoshop Masta
Joined
·
2,939 Posts
Discussion Starter · #1 ·
Hey guys. I just bought a Monster iCable after one of my friends was raving about the sound quality it provides. Well, after plugging it in the audio was/is TERRIBLE, sounds flat and I can hear what sounds like mic feedback with random crackles and pops. Anyone had this issue with their auxiliary port? My $5 radio shack auxiliary cable sounds great, I was just hoping for better sound quality, something this cable was 'supposed' to provide. Thanks!
 

·
that cranky admin
Joined
·
6,077 Posts
Hey guys. I just bought a Monster iCable after one of my friends was raving about the sound quality it provides. Well, after plugging it in the audio was/is TERRIBLE, sounds flat and I can hear what sounds like mic feedback with random crackles and pops. Anyone had this issue with their auxiliary port? My $5 radio shack auxiliary cable sounds great, I was just hoping for better sound quality, something this cable was 'supposed' to provide. Thanks!
Don't buy monster cables unless it is raw speaker wire. The rest is overpriced junk.

You shouldn't be noticing quality changes from a short straight male male aux cable unless the jacks are loose or corroded. Sounds like perhaps the jacks are loose or something.

Sent from my fingertips via magic
 

·
Registered
Joined
·
8,226 Posts
Don't buy monster cables unless it is raw speaker wire. The rest is overpriced junk.

You shouldn't be noticing quality changes from a short straight male male aux cable unless the jacks are loose or corroded. Sounds like perhaps the jacks are loose or something.

Sent from my fingertips via magic
Yup true story

Sent from my HTC6435LVW using AutoGuide.Com Free App
 

·
Registered
Joined
·
79 Posts
I have a 2013 so can't really help. But the sound quality on mine is kinda crappy at times. The bluetooth wireless connection makes the stereo sound weak. I plug in my iphone through the USB and it sounds better and good with electronic music, but anything with a full band has too much mid. It all just kinda muddles together and has no feel to the music if that makes sense. I haven't tried using the AUX.
 

·
Photoshop Masta
Joined
·
2,939 Posts
Discussion Starter · #6 ·
Well, I saw them in the stores for much more than what I was willing to spend for an auxiliary cable....but I bought one on eBay for WAY less, and it was brand new. I just read people with the same issue, guess I'll take the eBay users offer of getting a full refund.
 

·
Photoshop Masta
Joined
·
2,939 Posts
Discussion Starter · #8 ·
sounds like a defective wire to me
I don't know, it's an odd issue....my friend has one, I'm gonna try his on my iPod/car and see what happens, if I get the same problem then I guess it's just not compatible with my stereo/iPod.
 
1 - 9 of 9 Posts
Top