9th Gen Civic Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
After a long crank, the car may start up, otherwise I try cranking the 2nd time and it will start up. When this happens-- usually in the morning, I get all three codes at the same time: Power Steering, ABS, VSA. When this happens, my driving is still normal (or stiff steering wheel in rare cases) then the lights are gone after a few trips. What to do?

Faced this problem since I bought this 2012 civic at 55K miles. Now I have 110K miles. Still pass inspection every year. Starter replaced at 100K, same problem

Speedometer Vehicle Gauge Motor vehicle Tachometer
 

·
Registered
Joined
·
37 Posts
check your battery - if its voltage is good then check the positive (red) battery terminal and see if it has any build up of salts or signs of corrosion. If either gets bad enough the connection between the battery and the copper piece connecting it to the wiring harness might be bad enough to prohibit a proper flow of electricity.
 

·
Registered
Joined
·
383 Posts
sounds like a fuel pressure regulator issue for the long crank.

easy way to tell is key on for 10-15 seconds before cranking, if it fires up right away its the regulator.
 

·
Registered
Joined
·
7 Posts
After a long crank, the car may start up, otherwise I try cranking the 2nd time and it will start up. When this happens-- usually in the morning, I get all three codes at the same time: Power Steering, ABS, VSA. When this happens, my driving is still normal (or stiff steering wheel in rare cases) then the lights are gone after a few trips. What to do?

Faced this problem since I bought this 2012 civic at 55K miles. Now I have 110K miles. Still pass inspection every year. Starter replaced at 100K, same problem

View attachment 496039
I had the same codes for my 2015 si sedan. I swapped the abs modulator from a wrecked 2015 si coupe and codes never came back. However the car was diagnosed by a mechanic and I did the work myself.
 
1 - 4 of 4 Posts
Top