9th Gen Civic Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hello everyone,

About 2 years ago, I came here with my 2013 civic lx, VSA modulator throwing power steering, ABS, and anti-lock brake codes. I spent $1,600 to replace the VSA modulator at a Honda dealership. This solved all those lights for 2 years. On my way home last night, those codes came back! I can't believe my VSA modulator is giving me problems again. Has this ever happened to anybody else? Here is what the VSA, ABS fuse looks like. It does not appear to be blown to me. Does anybody have any suggestions? I'm getting really frustrated.

 

·
Registered
Joined
·
1,424 Posts
Whats your battery looking like? Fuse thingy doesn't look good to me, but i'm barely an armchair mechanic.
 

·
Registered
Joined
·
1,424 Posts
Battery is only 6 months old, and testing fine
Well then i'm out of ideas. I would start with checking terminals, just make sure its all tight and what not first, make sure not overlooking something simple. These cars are super sensitive to battery issues. Have you gotten the codes pulled?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Well then i'm out of ideas. I would start with checking terminals, just make sure its all tight and what not first, make sure not overlooking something simple. These cars are super sensitive to battery issues. Have you gotten the codes pulled?
Yes, I already checked the terminals and made sure they were clean. I'm stopping at Autozone after work today to pull the codes. However, the symptoms are the same as when my VSA went bad. ABS light comes on first, followed by Power Steering and Anti Lock Break Lights.
 

·
Registered
Joined
·
1,424 Posts
Yes, I already checked the terminals and made sure they were clean. I'm stopping at Autozone after work today to pull the codes. However, the symptoms are the same as when my VSA went bad. ABS light comes on first, followed by Power Steering and Anti Lock Break Lights.
That stinks bud. Good luck man. Maybe teeps will chime in with some info.
 

·
Registered
Joined
·
2,819 Posts
Without knowing if there are DTCs stored.
I got nothing either.
Other than check those battery cable connections at the battery, fuse boxes and chassis ground. Check VSA/ABS modulator connections and terminations too.
Also OP does your car have any electrical mods or aftermarket parts installed?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
I checked everything, fuses terminals, the connection to the ABS modulator, grounds I can't find anything. No aftermarket parts whatsoever. Stock all the way around.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
I went to AutoZone, advanced Auto, and pep boys, none would give me any abs codes, except pep boys who wanted $125 just to use their scanner.
 

·
Registered
Joined
·
10 Posts
I been having that VSA issue too but for me it would come on when I have too much wheel spin and no traction. Generally if I hit a dip or make sharp turn into uphill roads. It starts throwing those codes and then after a while of driving it would vanish like nothing happened. It is annoying, I'm wondering if my VSA modulator needs to be replaced too.
 
1 - 10 of 10 Posts
Top